Command Failed while "jovo deploy"



Since Jovo v3 i can’t deploy my Jovo-App.

Shortly after executing the command jovo deploy I get an error message while deploying the Interaction Model.

[ERR] Command failed: ask smapi set-interaction-model -s {SKILL-ID} -g development -l de-DE -p default --interaction-model "{\"interactionModel\" ................. }"

=> The command line is too long

I am using Jovo CLI 3.0.11.

The whole Interaction Model gets used in the Command and combined it is around 24000 Chars long. As far as I know, the Limitation from Windows 10 per Command is 8191 Chars.

Is there a way to fix this problem for now and will it get fixed in a future version of the CLI?


Hey @tobiasheymann,

yes, this is a current bug. Since the ASK CLI v2 migration, we had to find a way to insert the whole language model into the command line. On Unix-based systems, cat was the solution, but on Windows, this doesn’t work. The workaround was to use the whole stringified language model as a parameter, but as you can see this bears problems with large language models. I’m currently looking for a fix, happy to take suggestions!


Fixed it with the newest version. Please update using npm install -g jovo-cli.


Nice, thank you very much! :slight_smile: