Google Conversational Actions Notifications




I have been trying to follow the aforementioned tutorial for Conversational Action notifications but I cannot get it to work. I also copied the code from the associated GitHub repo to no avail.

In the en.json file there is a typo on line 20, “transitionToScene”: “PushNotificationScene_Notifications”, PushNotificationsScene is missing an ‘s’.

I’m getting a ‘There is no prompt message nor helper instruction in the response’ message in the simulator. The conditions are failing, I have tried setting the notification prompt directly in the google actions console to get permission, but this has not worked for me. Not sure if relevant, but in the Cloud Logs the ‘NotificationsSlot_PushNotificationsClickedIntent’ slot has properties of updated: true and status: ‘FILLED’ despite the error.

  "conditionsEvaluated": {
    "failedConditions": [
        "expression": "scene.slots.status == \"FINAL\" && (session.params.NotificationsSlot_PushNotificationsClickedIntent.permissionStatus == \"PERMISSION_GRANTED\" || session.params.NotificationsSlot_PushNotificationsClickedIntent.permissionStatus == \"ALREADY_GRANTED\")",
        "functionName": "Jovo",
        "nextSceneId": "actions.scene.END_CONVERSATION"
        "expression": "scene.slots.status == \"FINAL\" && session.params.NotificationsSlot_PushNotificationsClickedIntent.permissionStatus != \"PERMISSION_GRANTED\" && session.params.NotificationsSlot_PushNotificationsClickedIntent.permissionStatus != \"ALREADY_GRANTED\"",
        "functionName": "Jovo",
        "nextSceneId": "actions.scene.END_CONVERSATION"
  "responses": []

Would appreciate any help, I’ve been stuck on this for a while now!


Hey @Rik

I can reproduce it and was able to fix it by adding the prompt in the console manually

However, I get another error sending the push notification.

  error: {
    code: 403,
    message: 'The caller does not have permission',


Thanks for your reply @AlexSwe

That was something I tried yesterday, and it didn’t work. Just tried it again just now and I’m getting the same error. Are there any settings in the console that need to be configured? It seems like the Assistant doesn’t take over the conversation in my case.

Would you recommend building in Dialogflow instead?


Can’t find a solution for the 403 error :confused:

Are you developing the notifications for the en locale? I had issues with de.

I wouldn’t recommend switching back to Dialogflow. It would work, but I don’t think there will be any new features for it.


Hey @AlexSwe

I managed to get it working. I created a new action and it’s working now with the manual input of the notification prompt. The only difference was I created the first action in English(US) and the second one in English(UK). Not sure why that makes a difference but all good now! Thanks for helping.

I’m using en-GB. Notifications are coming through for me. I haven’t come across the 403 error.