Jovo Debugger: Load language model


When I run the jovo debugger I don’t see any of the intent options. What could be missing?


I fixed this by adding the samples back to the Amazon built in intents in my language model: image


Hm, weird.
Can you provide the model, that doesn’t work?

That worked for me:

	"invocation":"my test app",
				"say hello",
				"say hello world"
				"my name is {name}",
				"i am {name}",
				"you can call me {name}"


What happened was when I downloaded the model from ADC into my jovo project it had “samples” instead of “phrases” for the non-amazon specific intents.


In order to get newly added intents into the jovo debugger, does one need to manually add the intents to the language model file (for example into the file at C:\jovo\HelloWorld\models\en-US.json), or, is there someway to automatically get these downloaded from Amazon? I installed the CLI and tried jovo deploy, jovo build, etc, but nothing seems to be touching the file (if that’s the right file). Thanks in advance!