Jovo run connection error (Error: xhr poll error)


#1

I ran into this issue this morning. It looks like there is something wrong with the local prototyping webhook.

I’ve tried updating and re-installing the jovo-cli but that did not help. And it shouldn’t be an issue with my internet connection.

Running jovo run results in the following error:

Sorry, there seems to be an issue with the connection!
{ Error: xhr poll error
    at XHR.Transport.onError (/usr/local/lib/node_modules/jovo-cli/node_modules/engine.io-client/lib/transport.js:67:13)
    at Request.<anonymous> (/usr/local/lib/node_modules/jovo-cli/node_modules/engine.io-client/lib/transports/polling-xhr.js:130:10)
    at Request.Emitter.emit (/usr/local/lib/node_modules/jovo-cli/node_modules/component-emitter/index.js:133:20)
    at Request.onError (/usr/local/lib/node_modules/jovo-cli/node_modules/engine.io-client/lib/transports/polling-xhr.js:311:8)
    at Timeout._onTimeout (/usr/local/lib/node_modules/jovo-cli/node_modules/engine.io-client/lib/transports/polling-xhr.js:258:18)
    at ontimeout (timers.js:498:11)
    at tryOnTimeout (timers.js:323:5)
    at Timer.listOnTimeout (timers.js:290:5) type: 'TransportError', description: 503 }

I’m not sure what to make of the error, any help would be appreciated!


#2

I’m having the same error with jovo run so I cannot test my skill using the jovo webhook. Yesterday it was working fine. Seems like the SSL certificate for https://webhook.jovo.cloud/ expired a few hours ago. Is there something we can do to get it working again?

For now I’ve switched to bst-proxy to be able to test.


#3

Hi
I’m having the same problem, but i don’t know why. I’ll try work with ngrok or bst-proxy while the problem is solved.


#4

Seeing the same issue here.


#5

Thank you all for reporting the issue. Will work on fixing this!

For now, as mentioned by @Carleslc and @EverAcosta, I recommend using either bst-proxy or ngrok. Let me know if you have any questions setting it up