Lambda error with Alexa Skill



Hi! I have a problem, I made a properly working project on Alexa, I used the local jovo server. But after bringing everything on AWS Lambda gives me this error and I don’t understand the cause.
I tried to increase the time out limit but nothing changes.

“errorMessage”: “2020-05-20T17:47:46.784Z 09e676a0-76be-4e9f-8366-e980fe5b69fd Task timed out after 3.00 seconds”


Hi @Zimmo,

  • I’m assume you are getting the error when you try to launch the skill, correct? If so, have you tried testing the LAUNCH directly from the Lambda console? If you haven’t done this, it is pretty easy to add a test event within Lambda using the basic Alexa Start Session Event template and see if that executes correctly.

  • When you increase the timeout to 5 seconds, does the error message change to “Task timed out after 5.00 seconds”?

  • What do your cloud watch logs tell you? If you haven’t used CloudWatch before, it’s where all your log messages are going, and I use it all the time.

By the way, I’ve had similar Lambda behavior happen before - I think the usual culprits for me were unhandled Promises or an API call that was taking too long.



Thanks for the reply. It was a problem with Google Firebase that I resolved with this modify in index.js

// AWS Lambda

exports.handler = async (event, context, callback) => {
    context.callbackWaitsForEmptyEventLoop = false;
    await app.handle(new Lambda(event, context, callback));


Yes, I’ve been burned by the same issue before and resolved it the same way that you did. Nice catch.