Trigger settings for the lambda is invalid

amazon-alexa

#1

Hi,
Please help me with this:

I don’t know what is going wrong.

One more thing. I never receive any email notification if there is a reply! Do I need to change any account setting?

Regards,
Subrata Sarkar


#2

Added my response to the SO thread.

In a newly created Jovo project, the $ jovo deploy command creates a new Alexa Skill project.

This new project has a different Skill ID than the Skill project you’ve created by hand. This is why your trigger (which only accepts 1 Skill ID if verification is enabled) is complaining.

If you don’t want to create a new Skill project with the deploy command, you can also add the current Skill ID to your project.js (learn more here) file:

alexaSkill: {
    nlu: 'alexa',
    skillId: 'yourSkillId',
},

Then run the two commands again:

$ jovo build
$ jovo deploy