Contribute to jovo-cli



Hi Jovo Team,
I am trying to setup the jovo-cli locally to debug and contribute. The idea is to have a github clone /fork locally to understand what is happening when cli commands are not running correctly.
Therefore I cloned it on my computer + tried to set it up via npm run tsc. I also tried to follow your guide upon the jovo-framework ( But also the lerna commands are not working (+ the command devsetup is not available). So my first question is: How can I set it up to make it compile?

Second question:
I know that @AlexSwe used the workflow descriped in this link ( to locally test npm packages. Is this still the case? Can I use it to link my local jovo-cli, plugins and components?
Some additional information: I tried to link a local jovo component which seemed to work (-> I see it correctly in my node_modules). But when I am now trying to load it via jovo load ${componentName} the jovo cli fails:

Therefore I cloned the jovo-cli repo (to link it locally and test).

Thanks in advance =)


Thanks @Andre, will take a look! cc @rubenaeg


Hey @Andre,

the contributing link you mentioned isn’t suited for the Jovo CLI as far as I’m concerned. Try running npm run bootstrap and npm run tsc, or you compile the respective package you’re working in with the --watch flag enabled, this should get you going.

For the second question, I don’t quite understand what you’re trying to achieve here. Could you elaborate?


Hi @rubenaeg, with my second question I am trying to test my component locally. Momently the workflow is not good: I am updating the component code, make a git commit + push, load it in my other project via npm update + jovo load. Then I start testing.
I would like to test my changes locally and if everything is working I would like to make my commit.


Could you show me your linking process with the component?


@rubenaeg I move to the location of the component typing “npm link”. The terminal tells me that the symlink for “componentName” is created correctly in the global node_modules folder.
Then I process ``npm link componentName``` in my skills root folder which seems to work fine too. The component in the projects node_modules folder now points to the global node_modules project created before. I am able to use it for example via require in my project.
But running jovo-load-componentName and choosing “overwrite” leads to the error message above.