Exclude Google Assistant Health check from Analytics


Im currently running the Google Analytics plugin with my Jovo project and I was wondering if there is a way to exclude the data from the health check as that runs numerous times a day and makes it look like we have hundreds of users!


Hey @Adnan_Aga, are you using conversational google actions? Dialogflow actions already filter healthchecks. Like outlined here https://developers.google.com/assistant/console/health-checks conversational actions will call the intent HEALTH_CHECK. I don’t have a conversational action running to test it. @AlexSwe could you add a health check filter in the GoogleAnalyticsAssistant class?


Hey @Andre I am still running on the old Googe Actions platform since I started building and launched prior to the update and I have not migrated. But yes having a health check filter would be amazing!


@Adnan_Aga that’s strange. Dialogflow Health Checks Requests are already filtered - this is working for me since a longer time. Did you instantiate your google Analytics with method 1 or 2 (screenshot)?

In my opinion method 1 should make sure that there are no differences (instantiating both classes under the hood). But I did not find a constructor doing this.
Could you try method two (Initialize both classes in your app.js)?


So just to confirm,

I’m running jovo-platform-googleassistant: 3.5.1

In my config.js

GoogleAnalytics: {
   trackingId: 'UA-XXXXXXX'

I’m using method 1 like you described above

This is what I mean by a high amount of users only hitting the default welcome intent.



André made a pull request with a fix. It’s merged and published (jovo-platform-googleassistant 3.5.3)

Please run jovo update in your jovo project.


@Adnan_Aga I think you will have to use method 2 to enable platform specific tracking.