Google Actions Tutorial


#1

I decided to start over with the tutorial and did this:

[email protected]:/mnt/chromeos/GoogleDrive/MyDrive/Dev/jovo$ jovo new my-google-action --template google-conversational-actions-helloworld --locale en

jovo new: Creates a new Jovo project.

Learn more: https://jovo.tech/docs/cli/new

I’m setting everything up

:heavy_check_mark: Creating new directory /my-google-action
:heavy_multiplication_x: Downloading and extracting template google-conversational-actions-helloworld
→ EPERM: operation not permitted, chmod ‘/mnt/chromeos/GoogleDrive/MyDrive/Dev/jovo/my-google-action/.gitignore’
Installing npm dependencies…
› Error: There was a problem:
› Error: EPERM: operation not permitted, chmod ‘/mnt/chromeos/GoogleDrive/MyDrive/Dev/jovo/my-google-action/.gitignore’
[email protected]:/mnt/chromeos/GoogleDrive/MyDrive/Dev/jovo$ ls -l
total 8
drwxr-x— 2 johnxmurphy chronos-access 4096 Apr 21 14:39 my-google-action
drwxr-x— 3 johnxmurphy chronos-access 4096 Feb 22 17:39 rmr
[email protected]:/mnt/chromeos/GoogleDrive/MyDrive/Dev/jovo$

Permissions issue? But where?


#2

Seems like your user doesn’t have the necessary permissions. Maybe this one is helpful? (https://github.com/dlmanning/gulp-sass/issues/657#issuecomment-501000794)

Note: This seems to be an npm problem rather than a Jovo problem. This is why the GitHub issue I posted above is unrelated to our framework.


#3

I figured it out. I had been using Google Drive for all my data including Jovo. That worked on my ChromeBox 2. The ChromeBox 4 allows the implementation of a Linux local folder akin to the ChromeBook system. I copied the Google Drive folders over to Linux, That took six hours…

From the Linux folder I was able to deploy and run your “My test app”. Using the Google Console keyboard, I got the error "The test may not have the latest project changes. Try again later. " On my Google Home Mini the phantom voice told me I needed to “run Jovo” before I could use the app. When I did “Jovo run” on the Terminal, the app ran on voice but still shows the same error on the Google Console keyboard. I see that Auto Detect/Touch/Voice are enabled in the Console but not Keyboard. All four options return the same error.

So the only way to test for me is via voice on Google Home Mini. Me saying “OK Google” every minute irritates the hell out of my wife (lol).

I would like to port my existing Google Assistant voice app to Jovo so I can deploy it to other platforms such as Alexa. Do I have an option other than your Jovo Migration Service?


#4

Hm interesting, I haven’t seen this error before. Does it work if you reset the simulator?

There is no automated way, but maybe some of our partner agencies can help: https://www.jovo.tech/agencies