The new debugger doesn't work with my v3 project


Today I ran as usual “jovo run” and the new debugger appeared. Didn’t updated anything (all packages remains in v3.5). As it runs on domain, I assume that this debugger is updated for v4 so, can I bring back the old browser debugger? Didn’t found anything in the v4 docs. about this topic.


OK, I found how to do it: I uninstalled the jovo-cli package and installed it again. The jovo3 command opens debugger.

I think this must be warned in some way, maybe in the debugger?.


Now I get this error, after upgrading to Jovo 3.6:

Error -----------------------------------------------------------------

handleRequest.jovo.getRoute is not a function

TypeError: handleRequest.jovo.getRoute is not a function
at BasicLogging.routingLogger (C:\Develop\alexa\node_modules\jovo-framework\src\middleware\logging\BasicLogging.ts:96:27)
at App.emit (events.js:412:35)
at (C:\Develop\alexa\node_modules\jovo-framework\node_modules\jovo-core\src\core\Middleware.ts:95:21)
at App.handle (C:\Develop\alexa\node_modules\jovo-framework\node_modules\jovo-core\src\core\BaseApp.ts:271:7)
at App.handle (C:\Develop\alexa\node_modules\jovo-framework\src\App.ts:333:5)
at C:\Develop\alexa\src\index.js:20:9

This might be an issue with upgrading the Jovo packages. Try to run jovo update instead of npm install

Learn more:


Could you delete your package-lock, delete node_modules, and run npm install again?

Yes, you can find more information here:


Thanks jan, I tried removing package-lock.json and installing it again and solved the problem.

Anyway, the problem with v4 is that anyone that runs the debugger without knowing what’s going on is that he will see the v4 debugger and there’s no warning or info about the reason of not having any intent on it. I think that anyone running v3 must see a warning with instructions (please, reinstall jovo-cli package and use jovo3) or a link to the migration guide.


Hey @vaites

I fully agree! However, it’s hard to place a notice without updating the code.

This is what a v3 user sees in the Jovo Debugger

This banner might be too small.

This is what they get after jovo new <project>


Hi @AlexSwe, thanks for your help, but this is not the point. The first time I saw the new debugger I just thank “oh, a new design” but assumed that will work with my current version. Is not obvious…

The debugger might display a visible error like “The new v4 debugger is not compatible with your v3 project, please follow the instructions here to bring back the old debugger”.

Is just a suggestion, my problem is solved now. I’m just want to make it easier to others…


Have the Jovo debugger display its version name on that top line? That will at least give you something to tell the viewer to confirm… (Generally, I like having things with UIs announce their major version up front rather than buried under an “about” menu, but others may feel otherwise.)